This project is read-only.

Forms login problem

Dec 12, 2008 at 1:34 PM
I have changed the web.config so I can run the app in a different location than the default (localhost:30913). This is running ok, but I can get to access as anonymous user. I'm sure this is an stupid configuration problem but I can't get working.
any help?
Dec 12, 2008 at 6:03 PM
"This is running ok, but I can get to access as anonymous user."

I'm not sure what you mean.  Can you explain more?
Dec 15, 2008 at 8:29 AM
Well, I configured the application to run under my specific domanin (eg. and this is working. At first I got the redirect problem but I fixed it by changing the web.config from this:

<site name="Oxite Sample" host="http://localhost:30913" id="4F36436B-0782-4a94-BB4C-FD3916734C03" languageDefault="en" timeZoneOffset="-8" gravatarDefault="" />

to this:

<site name="Oxite Sample" host="" id="4F36436B-0782-4a94-BB4C-FD3916734C03" languageDefault="en" timeZoneOffset="-8" gravatarDefault="" />

This is running ok, I guess, but everytime I run oxite I got the forms authentication form instead of the I guess there is a problem becasue if I run the application in its original location (localhost:30913) it runs perfectly and with no forms authentication form until I click on the login link. How can I configure it so the app lets me see the default with no authentication required. I've been messing around with the <location path=""> in the web.config but with no luck, no, no css styles... just the authentication form.
Dec 15, 2008 at 6:04 PM
hhhmmm...all I can think off offhand is that something else is conflicting with it.  Do you have your Oxite app sitting underneath another application that it would inherit the web.config settings from?
Dec 17, 2008 at 8:55 AM
Edited Dec 17, 2008 at 8:56 AM
Nope, the application is running alone, no app over it.
I have the application in the vs 2008 projects folder, IUSR has permision to read, write (I gave it full control to see the effects, but with no luck either).
I'm running on Windows Vista Ultimate 64, IIS7, english installation.
I have anonymous allowed and forms login/redirect enabled.
I'm willing to use this application on a big project, even making modifications so it complies with accessibility standards (WAI/W3C), but I do need to get it running beyond localhost :). I'm sure it's some damn stupid thing...
Dec 17, 2008 at 8:58 AM
hhhmmm...try changing the app to run 32-bit instead of 64-bit.  I've got Oxite running in a hosted environment so it should work just fine.

Side note: Would love to hear what accessibility standards changes you'd suggest.  :)