Metaweblog API setup

Apr 14, 2009 at 7:00 PM
I've looked around for instructions and the only site I found was in another language!
Is there a good web source somewhere for info on how to move forward?

Thanks!
Coordinator
Apr 16, 2009 at 5:32 AM
I'm not sure I understand what you're looking to do.  Are you trying to use Windows Live Writer or something other blogging tool with Oxite?
Apr 16, 2009 at 8:40 AM
Quite right. Windows Live Writer.
Coordinator
Apr 16, 2009 at 8:42 AM
It runs you through a wizard to set up your blog.  Did you go down the custom blog route (or whatever it's called, I forget offhand)?  I believe it just asks you for the url of your site and a username and password.
Apr 16, 2009 at 8:52 AM
Edited Apr 16, 2009 at 8:53 AM
http://asvoqg.blu.livefilestore.com/y1p12qKVbt4RRPsPA1nj5IUbddm1iPWc0unoPCCH0T-cHMQKQuANiSeWri_-1U8yggihw2DkuDJ2G-C5UmEjQG2qWuy1Fs5YAqA/405%20Method%20Not%20Allowed.JPG

IIS7.
Coordinator
Apr 16, 2009 at 8:55 AM
Does it work when running it locally in IIS?
Apr 16, 2009 at 8:57 AM
I'm not sure I understand... the server is @ 127.0.0.1.
Coordinator
Apr 16, 2009 at 9:00 AM
Well then I'm not sure I understand.  If you run Oxite on your local machine then that would be the IP, but it looks like you're trying to connect to the web server that runs your domain.  I'm asking if it doesn't work in both places to see if it's a configuration problem with your web server or if something's really broken.
Apr 26, 2009 at 7:38 PM
Edited Apr 26, 2009 at 7:44 PM
Hey Erik,

I'm getting a similar error.  Is there a Handler that needs mapped to service *.svc files?  I removed Live Writer from the equation and simply typed the following URL into my web browser:

http://localhost/MetaWeblog.svc

And received the following IIS 7 error:

HTTP Error 404.3 - Not Found
The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.

Cheers,

Gabe Sumner

Coordinator
Apr 26, 2009 at 7:44 PM
The MetaWeblog stuff is done with WCF so I don't believe there's anything you need to setup for that.

If you're running Oxite locally through the ASP.NET Web Development server then the url should be this: http://localhost:30913/MetaWeblog.svc  Does that work?
Apr 26, 2009 at 7:48 PM
Ah.  I actually setup Oxite on my local IIS 7 server (not using Web Development server).  I wanted to simulate the IIS changes I would need to make during deployment.  It seems some type of Handler mapping needs to be in place to make this work.

Gabe Sumner
Coordinator
Apr 26, 2009 at 7:52 PM
Weird.  I thought *.svc "just works" out of the box with ASP.NET.  I know when I deployed my site ( http://erikporter.com ) to my IIS 7 host ( http://discountasp.net ), I didn't have to set anything up.  I'll see if the guy that wrote that code knows what might be going on...
Apr 26, 2009 at 9:58 PM
As it turns out, I didn't have WCF activated.  Here is the web site that led me to the solution:

http://blogs.msdn.com/davidwaddleton/archive/2007/11/02/wcf-and-404-3-errors.aspx

The fix is reposted below:

WCF Activation installed
  • This can be found under  the 3.0 framework options. Depending on your operating system this could be under different locations.
  • Vista  : Control Panel -> Program and Features -> Turn on/ off Windows Features -> Microsoft.NET Framework 3.0
  • Server 2008 : Server Manager -> Add Features-> .Net Framework 3.0 Features -> WCF Activatio

Thanks for your help Erik. 

Gabe Sumner

Apr 26, 2009 at 10:43 PM
Voila!
Thank you Mr. Sumner.
Sep 4, 2009 at 4:41 AM

I have the same problem (or, a similar one). I'm using Word, which manages to find the MetaWeblog service just fine, but when I go to post a blog entry (localhost, Win2008R2, IIS and WCF activation is enabled), it just fails.

Any ideas on how to debug this?