IIS 7 Deployment only shows NotFoundResult locally

Sep 2, 2009 at 3:21 AM

I'm having an odd problem which I think is some sort of trust issue.   When I make a non existent request locally I get the custom Oxite 404 page which is expected.  However, when I hit the same url from a remote browser I get IIS 7 404 server errors.  

Am I missing some IIS7 configuration magic somewhere?  

Thanks for any suggestions.

-Wick

Coordinator
Sep 2, 2009 at 3:57 AM

You will need to add <httpErrors errorMode="Detailed" /> to system.webServer in your web.config. The default is DetailedLocalOnly.

I just checked that in to CodePlex since most folks will need it in there.

From: wick [mailto:notifications@codeplex.com]
Sent: Tuesday, September 01, 2009 8:22 PM
To: Nathan Heskew (3^2)
Subject: IIS 7 Deployment only shows NotFoundResult locally [oxite:67665]

From: wick

I'm having an odd problem which I think is some sort of trust issue. When I make a non existent request locally I get the custom Oxite 404 page which is expected. However, when I hit the same url from a remote browser I get IIS 7 404 server errors.

Am I missing some IIS7 configuration magic somewhere?

Thanks for any suggestions.

-Wick

Read the full discussion online.

To add a post to this discussion, reply to this email (oxite@discussions.codeplex.com)

To start a new discussion for this project, email oxite@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Sep 2, 2009 at 4:35 AM

A little closer, but I can't quite make sense of the new error IIS is handing me:

----Config Error:  This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".-----

Sorry, I'm a bit of a newb to IIS7 configs...

-Wick

 

Coordinator
Sep 2, 2009 at 5:28 AM

You might have to allow overriding that in your appliicationHost.config (%windir%\system32\inetsrv\config\applicationhost.config), but if that’s the problem you might not have access to that config.

What’s the full error you’re getting (error code and all)? Are you putting this up on a shared host?

 

From: wick [mailto:notifications@codeplex.com]
Sent: Tuesday, September 01, 2009 9:36 PM
To: Nathan Heskew (3^2)
Subject: Re: IIS 7 Deployment only shows NotFoundResult locally [oxite:67665]

From: wick

A little closer, but I can't quite make sense of the new error IIS is handing me:

----Config Error: This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".-----

Sorry, I'm a bit of a newb to IIS7 configs...

-Wick

Read the full discussion online.

To add a post to this discussion, reply to this email (oxite@discussions.codeplex.com)

To start a new discussion for this project, email oxite@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Sep 2, 2009 at 4:12 PM

You're right on point Dr. Skewed.     I have full access to the machine and it was set to deny httpErrors overrides.   This fixed the problem and I appreciate your input and involvement in the Oxite project. 

Cheers,

-Wick